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 SpiderPad - Basic Editing

Selecting tags
You can select a tag by double-clicking it or by choosing Select Current Tag from the Edit menu.

Inserting tags
By choosing a tag from the Tags menu, one of two things happens: if text is selected, the start and 
end tags surround the selected text, with the cursor positioned after the end tag; otherwise, the start 
and end tags are inserted, and the cursor is positioned between the tags.

Inserting complex tags
Many tags have special attributes. The commands in the Insert menu present you with dialog boxes 
that let you easily define the attributes.

Modifying tags
To modify a tag, select the tag (or simply place the cursor inside the tag) and choose Current Tag 
from the Modify menu. If SpiderPad recognizes the tag, it will present you with a dialog containing the 
tag's current attributes, which you may modify as you wish.

Modifying attributes
To quickly change an attributes, you have another alternative. Select the tag you wish to modify and 
click the Modify menu. All the known attributes for that tag will be listed at the bottom of the menu. 
Choose the one you wish to change, and SpiderPad will prompt you for the new value.

Previewing your work
To preview your work, choose Preview from the File menu. The current document will be loaded into 
the browser of your choice. You must first specify a browser; See Preferences - Preview

Choosing files and URLs
In many of SpiderPad's dialogs you are allowed to choose files and/or specify URLs:

Clicking the  button will display a file browser.
Clicking the  button will display the URL builder.



 SpiderPad - Advanced Editing

This is an overview of some of the advanced editing features of SpiderPad.

Check-as-you-type
Check-as-you-type is available in the Preferences dialog under the Options menu. When enabled, it 
will wait until you finish typing a tag and then:

Color the tag.
Capitalize the tag and its attributes (if Uppercase tags is checked).
Order the attributes as they appear in the specification file.
Put quotes around the attribute values if necessary.
Verify that the attribute names are valid.
If the tag is unknown, ask you whether you want to add it to the list of CustomTags.

Attributes of custom tags will not be challenged by Check-as-you-type.
A tag can also be checked by choosing Check Tag from the Modify menu.

See Preferences - Editing, Customization

Finish Tag
Finish Tag will search backwards for the first unfinished tag, and insert the corresponding end tag. For
example, if you type <b>Bold and then choose Finish Tag, SpiderPad will make it <b>Bold</b>. 
SpiderPad will not finish tags it doesn't think need finishing (such as <br> and <hr>).

See Preferences - Editing.

Repeat Last Tag [Alt+Enter]

Inserts the last tag you selected from the Tags menu.

Navigate
At first glance this menu may not seem very useful, but by binding keyboard shortcuts to the menu 
items, you can simulate the navigation commands of other editors.

See Customization.

Select Text Between Tags
Selects the text between the end of the first tag before the cursor to the beginning of the first tag after 
the cursor.

Insert Line Breaks/Paragraphs
This command will add either a line break (<br>) or a paragraph (<p>) wherever it finds a newline in 
the selected text. This is useful after inserting a text file (and is not done automatically).



 SpiderPad - Working with Frames

Frames are a Netscape enhancement that allows HTML authors to partition the browser window into areas of different sizes, each 
containing a different HTML document.

Getting started
When you first select Frame from the Insert menu, the Frame editor is displayed with one frameset 
(selected) containing four equally sized frames. You can tell the frameset is selected because all of its
children are highlighted in orange.

At this point you should change the number of rows and columns of the frameset (unless four is what 
you want). Note that when you change the number of rows or columns in a frameset, all the data for 
its children get reset. 

Selecting frames
To select a frame, click on the frame.

To select a frameset, first select a child frame of the frameset, and click Select Parent. Alternatively, 
double-click a child frame.

Nested framesets
You can have nested framesets by changing an existing frame to a frameset. To do this, select the 
frame and then change the number of rows or columns to the desired number.

To change a nested frameset back to a regular frame, select the frameset (see above), and change 
both the number of rows and columns to 1.

Row and columns size
There are three options for specifying row and columns size: absolute sizes (in pixels), percentage of 
frameset width, and relative. Percentages are numbers followed by a percent symbol (%), relative 
sizes are numbers followed by an asterisk (*), and absolute sizes are just numbers. See an HTML 
reference for more details.

The current size of a row/column is shown when a frame in that row/column is selected. A comma-
separated list of all row/column sizes is shown when a frameset is selected. You may modify either of 
these to change row and columns sizes.

Modifying an existing frame
Modifying an existing frame is the same as modifying any other tag; select the frame, or place the 
cursor in the <frameset> tag, and choose Modify Current Tag from the Modify menu.



 SpiderPad - Working with Tables

Selecting cells
The current table is shown in the left hand side of the window. Click a cell to select it. When a cell is 
selected, it is a lighter color than normal. If you hold SHIFT while clicking you can select or deselect 
multiple cells. 

Changing attributes
The right hand side of the window is broken into three sections. The top section contains table 
attributes, the middle section row attributes, and the bottom section cell attributes.

To change a row's attributes, select any cell(s) from that row. You may only modify one row's 
attributes at a time.

When multiple cells are selected, heading and alignment attributes changes affect all selected cells.

Adding and deleting rows and columns
To add a row or column, select a cell and click the appropriate button. Rows are added above the row
of the selected cell, and columns are added to the left of the selected cell.

To delete a row or column, select one cell from the row or column you wish to delete, and click the 
appropriate button. Note: none of the cells in the row or column may be merged cells.

Merge and Split
You may merge two or more contiguous cells into one by selecting them (use SHIFT to select more 
than one cell) and clicking the Merge button. Cells to merge must be contiguous, and lie entirely in a 
single row or column. For example, to merge a square of four cells, you must merge the top two, then 
the bottom two, and then the two merged cells together.

A merged cell may be broken into its constituent cells by clicking the Split button. The Split button has
no effect on unmerged cells.

Show Text
SpiderPad attempts to show you how each cell's text will be aligned within the cell (based on cell 
alignment/heading attributes and row alignment). If you do not wish to have the text displayed, 
uncheck the Show Text option

Modifying an existing table
Modifying an existing table is the same as modifying any other tag; select the table, or place the 
cursor in the <table> tag, and choose Modify Current Tag from the Modify menu.

Converting a tab-delimited ASCII table
SpiderPad can automatically convert a tab-delimited table to HTML. Insert the table into a document, 
select the table, and choose Insert Table from the Insert menu. SpiderPad will ask you if you want to 
do with the selected text: import or replace. Choose import, and the converted table will be loaded 
into the Table Designer (choosing replace will replace the selected text with the new table).



 SpiderPad - Extended Characters

Extended Characters F8

You may insert extended characters (foreign, currency, etc.), by choosing Extended Characters from 
the Window menu. This will present you with a table of the available characters and their HTML 
equivalents. Double-clicking a cell will insert its contents into the current document.

There is a Close box in the upper-right corner of the Extended Characters window. Checking this will 
cause the window to close after you insert a character.

Replace Extended Characters
This command searches the selected text for extended characters and replaces them with their HTML
equivalents (such as &Atilde; for Ã). This is handy if you wish to work with the actual characters while 
writing a document, and then convert them at the end.

Auto-replace &,>,< F5

SpiderPad lets you automatically replace extended characters while typing by enabling Auto-replace 
&,>,< from the Preferences dialog in the Options menu. All extended characters (including foreign 
characters for those of you using foreign keyboards) will be transformed into their HTML equivalents.



 SpiderPad - Working with Forms

Introduction
Form design is broken up into two windows, the Form Builder window and the Form Layout window. 
To get started, drag a form element from the Form Builder window onto the Form Layout window.

Select a form element in the Form Layout window by clicking on it. The attributes applicable to that 
type of form element will be displayed in the Form Builder window.

Hold SHIFT to select multiple form elements. If the elements are of a single type, their attributes are 
displayed in the Form Builder window for modification.

Moving elements
After dragging form elements from the Form Builder window to the Form Layout window, you may 
reposition the elements by dragging them around. To drag multiple elements, first select the elements 
and then drag one of the elements to its new position.

Copying elements
Select the element you wish to copy, and click the Add Another button. A copy of the element, with the
same attribute values, will be created and placed underneath. If you click Add Another with no 
elements selected, a copy will be made of the last element added.

Notes on layout
All elements side by side in the Form Layout window will have nothing separating them in the 

HTML output.
Two elements above and below each other will be separated by a newline character and a line 

break <br>.

A completely blank line separating two elements will be interpreted as a paragraph break <p>.

The positions of Option elements has no effect on the layout of the form (see below).

Notes on special elements
html It is common to have HTML text interspersed between the <input> elements (for 

example, to indicate the purpose of a Text element). The HTML elements lets you insert 
"raw" HTML text anywhere in the form.

option In HTML, the Select element lets the user choose from a list of options. The options are 
implemented here as separate form elements. You must specify a group for each option; 
this will be the name of the appropriate Select element. Note that in the final HTML 
output, the options will always appear within the <select> tag, regardless of their positions
on the Form Layout window.

Modifying an existing form
Modifying an existing form is the same as modifying any other tag; select the form, or place the cursor
in the <form> tag, and choose Modify Current Tag from the Modify menu.



 SpiderPad - Customization

SpiderPad is fully customizable. You can modify the toolbar and right-mouse menu, assign keyboard shortcuts to any command, 
and create your own custom tags. 

The Command Window
The toolbar, right-mouse menu, and keyboard shortcuts are customizable by choosing Commands 
from the Options menu. To select a command, you may choose it from the list of all commands, click 
a toolbar button in the main SpiderPad window, or choose a menu item from the main SpiderPad 
window. After you have chosen a command you may change its shortcut or add it to the toolbar or 
right-mouse menu.

Click below for more information on the Commands window:

Custom Tags
The Tags menu includes a Custom submenu which you can edit via the Custom Tags item in the 
Options menu. You are required to give the tag a name, and then optional start and end tags. The 
start and end tags must be the full tags, including the less-than and greater-than characters, such as 
<blink> and </blink>.

Custom tags can be assigned keyboard shortcuts as with the other menu items.

Custom tags can be automatically created when you type unrecognized tags by turning on the Check-
as-you-type option. See Preferences - Editing



Shortcut
Displays the shortcut of the current command. To change, select a new shortcut and press the Set 
button.

If you try to assigned a shortcut that is already assigned you will be asked to confirm the 
reassignment.



Close Button
Closes the Commands window. Asks you if you want to save changes to toolbar or right-mouse 
menu.



List of All Commands
Lists all commands, including all predefined and custom tags. Choose a command from this list to set 
the current command.



Toolbar Tab
Displays a list of the toolbar buttons for modification.



Right-button Tab
Displays a list of the right-button menu commands for modification.



Toolbar/Right-button menu Command List
Lists the commands of either the toolbar or right-button menu. You may select more than one 
command at a time. Separators are displayed as hyphens ("-").



Remove Button
Removes the selected command(s) from the list of toolbar/right-button-menu commands.



Add Button
Adds the current command before the selected command(s) in the list of toolbar/right-button-menu 
commands.



Add Separator Button
Adds a separator to the list of toolbar/right-button-menu commands. The separator is displayed as a 
hyphen ("-").



Move Buttons
Moves selected command(s) up or down in the list.



Current Command
Displays the currently selected command. This is the command that will be added to the toolbar or 
right-mouse menu when you click the Add button. You may choose the current command by choosing
a command from the list above, clicking on a toolbar button from the main SpiderPad window, or 
choosing a menu item from the main SpiderPad window.

You may also change how the command will be displayed on the toolbar by clicking on the text or 
graphic button.



 SpiderPad - Working with Templates

Templates are HTML documents that, when loaded into SpiderPad using the New From Template command, query you for 
information that gets inserted into the template document. They are useful for quickly generating many pages that have only slight 
differences.

How templates work
A template is just a regular HTML document that includes SpiderPad's special <prompt> tags. When 
you choose "New From Template" from the File menu, SpiderPad searches the HTML file you open 
for the <prompt> tags, and presents dialog boxes prompting you for information that gets inserted in 
place of the tag.

Making your own templates
You can make your own templates by adding <prompt> tags to an existing HTML document. Choose 
Prompt from the Insert Menu.

Look at template.htm (included with SpiderPad) for examples of the <prompt> tag.

Date and Time prompts
The Date and Time prompts act differently. They do not ask you for any information, but just go ahead
and fill it in automatically.

Using previous prompt values
Sometimes you may just want to prompt for a piece of information once, and use the answer 
throughout the template. To do this, give the first prompt a name, and then set the previous attribute 
of each prompt that will use the same answer to that name.

Fill-in Prompts
This command, available in the Tags menu, searches the current document for <prompt> tags, just as
New From Template does. Use it to test your templates.



 SpiderPad - Preferences

All of SpiderPad's preferences are available from the Preferences dialog box in the Options menu.

Go To
Editing

Appearance

Links

Preview

Saving preferences into file
You can save your current preferences into the current document by choosing Save Prefs. info File 
from the Options menu. This will insert a tag with the preferences as attributes into the top of your 
document. The next time you load the file you will be asked if you want to load the preferences.

Choosing Save Prefs. into File when there are already preferences saved will cause the old 
preferences to be replaced with the new ones.



 SpiderPad - Preferences - Appearance

Tag Colors
You may change the color of text, normal tags, children tags (such as <li>, <dt>, <frame>), 
comments, and the background. Choose the item you want to change from the drop-down list and 
click on the desired color.

Color when loading
When checked, opened documents are automatically colored. This can slow loading of large files.



 SpiderPad - Preferences - Links

Relative links
Links to local documents can be either absolute (such as "file:///c|/html/sample.html") or relative (such
as "../sample.html"). If they are relative, they need to be relative to something. SpiderPad lets you 
choose that links are relative to the directory of the current document or to a different directory.

Local link translation
For absolute links, there are a variety of addressing schemes around. Choose the scheme that is 
most appropriate for your audience. You may also specify that all filenames are forced to lowercase.



 SpiderPad - Preferences - Preview

SpiderPad lets you preview your documents in the browser of your choice, either by saving and loading the current document or by 
saving to a temporary file.

Browser location
Type the full path of your browser here, or click the  button and choose one.

Save current document / Use temporary file
You can either make SpiderPad save the current document and load it into your browser, or save the 
current document to a temporary file. Using a temporary file when previewing will allow you preview 
an unsaved document. The disadvantage is that relative links will not work, because the temporary 
files are not saved to the same directory as the original document.



 SpiderPad - Preferences - Editing

Uppercase tags
If this option is checked, when choosing tags from the Tags menu, inserting tags using the Insert 
menu, or (if Check-as-you-type is turned on) typing tags from the keyboard, SpiderPad will capitalize 
all tag and attribute names.

Protect tags
Checking Protect Tags turns on rudimentary tag protection. You cannot backspace into a >, or delete 
into a <. 

Only one title/body
You are only supposed to have one title and one body tag per document. If this option is checked, 
choosing Insert Title or Insert Body from the Insert menu will cause SpiderPad to search for an 
existing title or body tag, and modify it if it exists. Uncheck this only if you have a need to insert 
multiple title and body tags.

Finish optional tags
Some tags, like table tags (<tr>, <td>) or list items (<li>) commonly have their end tags omitted. By 
default, SpiderPad does not add these end tags when you use the Finish Tag command, or when you 
insert/modify tags using the tag dialogs. Checking Finish All Tags will force SpiderPad to insert end 
tags for all these tags.

<P> as Container
While it is common to omit the end </p> tag for paragraphs, some prefer the container structure. 
Checking this option will insert the end tag when you choose Paragraph from the Tags menu. See 
also Finish All Tags, above.

Check-as-you-type
Check-as-you-type is available in the Preferences dialog under the Options menu. When enabled, it 
will wait until you finish typing a tag and then:

Color the tag.

Capitalize the tag and its attributes (if Uppercase tags is checked).

Order the attributes as they appear in the specification file.

Put quotes around the attribute values if necessary.

Verify that the attribute names are valid.

If the tag is unknown, ask you whether you want to add it to the list of CustomTags.
Attributes of custom tags will not be challenged by Check-as-you-type.
A tag can also be checked by choosing Check Tag from the Modify menu.

Check for overlap



Check for overlap makes SpiderPad look for and eliminate overlapping tags of the same type when 
you choose a tag from the Tags menu. Here is an example:

Use Extensions From
SpiderPad supports Netscape Navigator and Microsoft Internet Explorer extensions. If extensions are 
enabled, browser-specific attributes will appear in the Modify menu, and Check-as-you-type will not 
complain when it comes across a browser-specific tag or attribute. Also, some dialogs such as the 
table builder and body tag builder change with respect to which browser is enabled.

Save as UNIX File
Replaces newlines (CRLF) with linefeeds (LF) when saving. Note that UNIX files are automatically 
converted when opened.

Auto-replace &, >, <
Replaces reserved characters with their HTML equivalents. See Extended Characters.

Undo Levels
Changes the number of undo and redo levels for each SpiderPad document. Changes take effect the 
next time you run SpiderPad.



 SpiderPad - Command Reference

Below are links to descriptions of all the commands in each of SpiderPad's menus.

Menu
File

Edit

Insert

Modify

Tags

Options

Window

Help



 SpiderPad - Command Reference - File Menu

See Command Reference

New
Opens a new (empty) document for editing.

New from Template
Prompts you to choose a template file, then loads the file into an untitled document and runs the Fill-
in Prompts command. See Working with Templates.

Open
Opens an existing document for editing.

Close
Closes the current document.

Insert
Inserts a file into the current document at the cursor location. Converts UNIX files if necessary.

Preview
Loads the current document into your browser. See Preferences - Preview.

Save / Save As…
Saves the current document. Save As will prompt you for a new file name.

Exit
Quits SpiderPad.



 SpiderPad - Command Reference - Edit Menu

See Command Reference

Undo / Redo
Undos the previous command, or redos a command that has been undone. The number of undo 
levels is specified in the Preferences dialog; See Preferences - Editing.

Cut / Copy / Paste
Performs the respective clipboard action.

Clear
Erases the selected text.

Kill Rest of Line
Erases the text from the cursor to the end of the line. Erases the line if it consists only of a newline 
character.

Recolor / Recolor Document
Recolor will recolor the selected text, or the current paragraph if no text is selected. Recolor 
Document recolors the entire document (it's faster than Select All and Recolor). See Preferences - 
Appearance.

Select All
Selects the text of the entire document.

Select Current Tag
Selects the tag that the cursor is currently inside.

Select Text Between Tags
Selects the text between the end of the first tag before the cursor to the beginning of the first tag after 
the cursor.

Move (Forward / Backward / Next Line / Previous Line)
Moves the cursor in the direction specified.

Jump (Start of Line / End of Line / Start of File / End of File)
Causes the cursor to jumps to the specified location. 

Replace Extended Characters
Searches the selected text for extended characters and replaces them with their HTML equivalents 
(such as &Atilde; for Ã). See Extended Characters.

Insert Line Breaks / Paragraphs
Adds either a line break (<br>) or a paragraph (<p>) wherever it finds a newline character in the 
selected text. This is useful after inserting a text file (and is not done automatically).



 SpiderPad - Command Reference - Insert Menu

See Command Reference

Form / Frame / Heading / Image / Prompt / Table / Link / Anchor
Displays the appropriate tag builder. Inserts the new tag into the current document.

See Working with Forms.

Working with Frames.

Working with Tables.

Working with Templates.

RGB Value
Displays the color chooser. Inserts chosen color into current document in "#RRGGBB" format.

Quick Link
Uses the selected text as the value of the HREF attribute of a link.

Title / Body Tag
If the Only one title/body option is on, searches for and lets you modify existing title or body tag. 
Otherwise displays the appropriate tag builder, and inserts the new tag into the current document. 
See Preferences - Editing.



 SpiderPad - Command Reference - Modify Menu

See Command Reference

Current Tag
Selects the current tag and displays the appropriate tag builder with all the attributes of the tag 
loaded.

Check Tag
Checks the current tag and corrects it if necessary. Same features as Check-as-you-type: See 
Preferences - Editing.

Attributes
At the bottom of the Modify menu are the attributes for the currently selected tag. Clicking one will 
prompt you for a new attribute value.

Netscape and Internet Explorer attributes are only displayed if their extensions are enabled. See 
Preferences - Editing.



 SpiderPad - Command Reference - Tags Menu

See Command Reference

Repeat Last Tag [Alt+Enter]

Inserts the last tag you selected from the Tags menu.

Finish Tag
Searches backwards for the first unfinished tag, and inserts the corresponding end tag. SpiderPad will
not finish tags it doesn't think need finishing (such as <br> and <hr>).

See Preferences - Editing.

Fill-in Prompts
Searches the current document for <prompt> tags and prompts you to fill in the desired information.

Remove Tags / Comments
Removes all tags or comments from the selected region.



 SpiderPad - Command Reference - Options Menu

See Command Reference

Commands… / Custom Tags…
See Customization.Preferences

Save / Load Prefs. into / from File
See Preferences.



 SpiderPad - Command Reference - Window Menu

See Command Reference

Extended Characters…
Shows the extended character window. Double-clicking a cell will insert its contents into the current 
document. When the Close box in the upper-right corner of the window is checked the window will 
close each time you insert a character. See Extended Characters.

Cascade
Cascades all document windows.

Tile Horizontally / Vertically
Tiles all document windows either side-by-side or above and below each other.

Arrange Icons
Arranges the document icons.



 SpiderPad - Command Reference - Help Menu

See Command Reference

Contents
Opens this help file to the Table of Contents.

Search for Help On…
Lets you search this help file for a specific topic.

Using Help
Documentation on using these help files.

About…
Version and registration information for SpiderPad.



 SpiderPad - More Information

For up to date information on SpiderPad, including how to order the latest version of SpiderPad, please visit our web site.

http://www.sixlegs.com/




